Communication Loss to Controller

Troubleshoot the error message "Unable to retrieve information from the controller. Ensure you have a valid connection to the controller and try again."

Problem

Communication loss to controller.

"Unable to retrieve information from the controller. Ensure you have a valid connection to the controller and try again."

Causes

  1. Incorrect IP address and/or subnet mask set on the controller.

  2. Incorrect IP address set in Transverse/ Inline software.

  3. Incorrect IP address and/or subnet mask assigned on the PC.

  4. Possible duplicate IP address on the network.

  5. Physical connection issue; RJ45 connector at the controller and/or at the PC/network switch.

  6. Firewall settings.

  7. Faulty Rabbit Card and/or controller card.

Solution

You first need to determine how the controller is connected to the PC. It will either be direct, or via a network switch.

Ping the controller using the windows command prompt. Example: "ping 192.168.1.202" to determine if the controller is visible on the network. If successful, perform a continuous ping test to determine if the problem is intermittent. Example: "ping -t 192.168.1.202". Press Ctrl+C to stop ping.

  1. If you do not get a valid ping response, make sure the controller IP is correct (see Configuring an IP/Subnet on a Controller)

  2. If you did not receive a valid ping response on the first ping, but are getting intermittent responses when doing the continuous ping test, perform tests in number 3.

  3. If connected via a network switch, run a direct cable direct from the controller to the PC and configure the network settings accordingly. If connected directly to the PC already, go to the MCU and look at the LED's on the rabbit card. There should be a solid green light and a flashing amber. If the green LED is intermittent, re-seat the connection at the rabbit card and MCU. Then, measure the 5VDC on the controller card and confirm it is above 5VDC.  The rabbit card requires a minimum of 5VDC to operate correctly.  If not, then try a new power supply. If that does not work, ensure the power supply has a load by connecting a 3W 10Ohm resistor between common and 5VDC at the power supply.

  4. If comm loss persists, disconnect the rabbit card from the network and ping the address again. If it pings then the IP is a duplicate. This needs to be identified by the site and the controller will need a new assigned IP address.

  5. Verify the PC's firewall settings.

  6. Replace Rabbit Card

Applies To

2400, 1500 & 2500